Avocent DSView Software Downloads

DSView Hardware Compatibility Status

The following EOL products will not receive support in DSView 4.5 SP5 or newer:

  • The full DSR product family (DSR10xx, DSR20xx, DSR40xx, DSR80xx)

  • The full Cyclades product family (CCSxxxx)

  • The ACS Classic family (LSL10xxA, AP930x, ATPxxxx, ACS48/26K7649, ACS48/26K7715)

DSView Plug-In and a firmware upgrade are required to ensure full management capability by DSView 4.5 SP5 and newer. Please refer to the table below to identify the earliest compatible versions.

ProductDSView PlugInFirmware

ACS 5000

3.3.7

3.3.0-18

ACS 6000

3.3.0.7

3.3.0.12

ACS 8000

1.0.0.5

1.0.1

PM 1000/2000/3000

2.0.1.8

2.0.1.23
2.1.0.23 (INTL)

MPH (with RPC2)

1.1.1.2

11.0.0.7

MPH2 (with RPC2)

1.1.1.2

11.0.0.7

MPX (with RPC2)

1.1.1.2

11.0.0.7

UMG

3.3.0.26

3.1.2.10

AutoView 2108/2216

1.20.1

1.20.0

AutoView 3108/3216

1.22.0

1.22.1

MPU

1.32.0

1.32.0


To Register for Software Downloads from Vertiv:

  1. Click “Register”.
  2. Complete all required fields (*).
  3. Accept Terms and Conditions.
  4. Click "Create Account". An Activation Code will be emailed to the email address specified in the account creation process.
  5. Activate the account by entering the Activation Code on the portal page.

*Please review the FAQ if you are a former Avocent ACE portal user.

To register software tokens and download the application, please Log In with your account credentials.

;